How to Fix dyld: code signature for shared cache failed with errno=7 During Jailbreak with Redsn0w | iPhoneJailbreak.me

How to Fix dyld: code signature for shared cache failed with errno=7 During Jailbreak with Redsn0w

November 26th, 2012 5 Comments

This is a common error encountered by users but it can be fixed quite easily.

You are getting that error because you are supposed to point redsn0w at the firmware your iPhone is currently on.

For example, if your iPhone is currently on iOS 5.1.1 or 5.0.1, pointing redsn0w to a different iOS version will cause this error.

You must point redsn0w to the same iOS version and also you must NOT point it to custom iOS (IPSW), only original firmware can be processed by redsn0w.

1.Go to Extras

2. Select IPSW and select the original IPSW you have downloaded.

3. Proceed with next steps.

Here are the latest redsn0w download links:

Related Posts Plugin for WordPress, Blogger...

Richard Ker

An IT specialist by day and an iPhone hardware repair specialist by night. Enjoys iPhone jailbreaking, unlocking and hardware hacks.

Website - More Posts



unlock iOS 6.1.3  

Sign up Free Email Newsletter

Stay Updates with this Blog. Get Free email newsletter updates, Enter your Email here:

Don't forget to confirm your email subcription

   

5 Comments to “How to Fix dyld: code signature for shared cache failed with errno=7 During Jailbreak with Redsn0w”

  1. Carl says:

    I'm getting this problem on my iphone 3gs after upgrading to 6.0.1 Tried to downgrade by selecting the ioS 5.1.1 and getting this error so should I download the ios 6.0.1 and try running redsnow using this IPSW?

  2. CountryTripper says:

    Hi,

    The above fix is fine if you’re running below 6.01. redsn0w 0.9.15b3 does not recognise 6.01 firmware to select, nor 6.0. The only IPSW that it would let me select is 5.1.1. Doing that provided the above issue for me also. I realised why, but there doesn’t seem to be a fix I can find when redsn0w 0.9.15b3 just wont accept it.

    Any assistance would be great.

    Kindest Regards

  3. Alban says:

    IOS 6.0.1 is not supported by redsn0w 15b3…. what can I do to downgrade the baseband?

Leave your comment here:

unlock iOS 6.1.3


Enter your email address:

Delivered by FeedBurner

Categories